[戻る]
過去ログ [ 0001 ]
過去ログ:     ワード検索: 条件: 表示:

タイトル
記事No
投稿日
投稿者
参照先
xc8が認識されず困っています。
618
: 16/07/05-14:51
hayashi <ee1517@yahoo.co.jp>

mplab x ide v3.35をインストールしてxc8 v1.37をインストールしましたが、mplabを起動すると次のようにメッセージが出てコンパイラが認識されませんでした。

No suitable compilers were found on your system. The IDE needs a suitable set of compilers and other build tools in order to work correctly.

If you already have compilers on your system but they were not found, do one of the following:

1) Exit the IDE, add your compilers to your PATH environment variable, and restart the IDE.

2) Open the Build Tool dialog in Tools | Options | Embedded | Build Tools and add your compiler(s) to the setup.

If you do not already have compilers on your system, do:

3) Download and install a suitable set of compilers and restart the IDE.

コンパイラを追加しようとして、Tools→options→Embedded→build tools でaddからxc8のフォルダを開きbinのフォルダを選択してもBase directory does not contain a toolchainと出ておりうまくいきません。

解決方法がありましたらよろしくお願いします。
▲pagetop
タイトル
記事No
投稿日
投稿者
参照先
Re: xc8が認識されず
621
: 16/07/05-16:45
Gokan <gokan@picfun.com>

Tools→Options→Embedded→build tools のダイアログで
「Scan for Build Tools」のボタンをクリックしていみてください。

> mplab x ide v3.35をインストールしてxc8 v1.37をインストールしましたが、mplabを起動すると次のようにメッセージが出てコンパイラが認識されませんでした。
>
> No suitable compilers were found on your system. The IDE needs a suitable set of compilers and other build tools in order to work correctly.
>
> If you already have compilers on your system but they were not found, do one of the following:
>
> 1) Exit the IDE, add your compilers to your PATH environment variable, and restart the IDE.
>
> 2) Open the Build Tool dialog in Tools | Options | Embedded | Build Tools and add your compiler(s) to the setup.
>
> If you do not already have compilers on your system, do:
>
> 3) Download and install a suitable set of compilers and restart the IDE.
>
> コンパイラを追加しようとして、Tools→options→Embedded→build tools でaddからxc8のフォルダを開きbinのフォルダを選択してもBase directory does not contain a toolchainと出ておりうまくいきません。
>
> 解決方法がありましたらよろしくお願いします。
▲pagetop
タイトル
記事No
投稿日
投稿者
参照先
Re^2: xc8が認識されず
626
: 16/07/06-15:13
hayashi <ee1517@yahoo.co.jp>

Scan for Build Toolsを押してもコンパイラが検出されませんでした。

バージョンを落としたところコンパイラが正常に認識されました。
ご返信ありがとうございます。
▲pagetop

- WebForum -