[戻る]
過去ログ [ 0001 ]
過去ログ:     ワード検索: 条件: 表示:

タイトル
記事No
投稿日
投稿者
参照先
MPLAB X IDE V3.00
251
: 15/06/10-17:50
REF14270

MPLABX IDE V2.30とXC8 V1.33を使っていますが、
MPLAB X IDE をV3.00にアップデートしたら次の症状が出て困っています。

V2.30では問題が無かった記述で、赤いアンダーラインが表示される。
例えばStartI2C();やOpenTimer1(TIMER_INT_ON & T1_16BIT_RW・・・
のカッコ内のパラメータの下に赤いアンダーラインが表示されます。

マウスをその上に置くとUnable to resolve identifier StopI2C
と表示されます。(ただしコンパイルは正常に終了します)

アンダーラインを消すため、Editor->Hintsタブで、
Unresolved Identifier のチェックを外すと消えますが
本当に間違えた記述に赤アンダーラインが出ない。
になります。

対処方法があったら教えてください。
よろしくお願いいたします。
▲pagetop
タイトル
記事No
投稿日
投稿者
参照先
Re^2: MPLAB X IDE V3.00
253
: 15/06/11-12:42
REF14270

MOT 様

早速のご回答ありがとうございました。
ご指摘のございました箇所、
#include <i2c.h>
#include <usart.h>
をコメントにしていました。
コメントを外し有効にしたら問題はありません。(失礼しました)

MON様のおっしゃる通りV3.00にしたらキーマップやTAB設定等も初期値に戻っていました。
以前は古いバージョンをアンインストールしなけらばならなかったですが、
V3.00はそのままインストールできましたね。
古いバージョンは使用しなけらばアンインストールしても問題ないでしょうか・・?

ありがとうございました。また教えてください。



> パスが切ってあったりしませんでしたか。
> 3.0にアップデートすると,それ以前のユーザー設定例えば,履歴,キーマップなど
> すべてがクリアされるようです。
> (今まで通りのインストール方法です。設定クリアしない方法があるかのも)
>
> 該当ファイルを絶対パスで指定したらどうなりますか? 例えば,
> #include "C:\Program Files\Microchip\xc8\v1.34\include\plib\i2c.h"
>
> > MPLABX IDE V2.30とXC8 V1.33を使っていますが、
> > MPLAB X IDE をV3.00にアップデートしたら次の症状が出て困っています。
> >
> > V2.30では問題が無かった記述で、赤いアンダーラインが表示される。
> > 例えばStartI2C();やOpenTimer1(TIMER_INT_ON & T1_16BIT_RW・・・
> > のカッコ内のパラメータの下に赤いアンダーラインが表示されます。
> >
> > マウスをその上に置くとUnable to resolve identifier StopI2C
> > と表示されます。(ただしコンパイルは正常に終了します)
> >
> > アンダーラインを消すため、Editor->Hintsタブで、
> > Unresolved Identifier のチェックを外すと消えますが
> > 本当に間違えた記述に赤アンダーラインが出ない。
> > になります。
> >
> > 対処方法があったら教えてください。
> > よろしくお願いいたします。
▲pagetop

- WebForum -